記事の詳細

WordPressのプラグインの中で、「timthumb.php」というプログラムを含んでいるものには虚弱性が報告されています。この虚弱性はtimthumb.phpのバージョンが古いことが問題になっているようで、「TimThumb Vulnerability Scanner」というプラグインを使うことで新しいバージョンにアップデートすることができます。

「TimThumb Vulnerability Scanner」の導入・設定方法

1.WordPressの管理画面から「プラグイン」「新規追加」をクリックして「Timthumb Scanner」を検索します。

2.「TimThumb Vulnerability Scanner」が見つかるので「いますぐインストール」の文字をクリックします。

3.インストールが完了するので「プラグインを有効化」します。

4.「ツール」「Timthumb Scanner」が追加されているのでクリックします。

5.「Scan!」のボタンを押します。

6.古いバージョンのファイルが検出されたら、チェックを入れ「Upgrade Selected Files」ボタンをクリックします。

7.Statusの文字が緑色に変わったらファイルのアップグレードは完了です。



関連記事

ページ上部へ戻る